PHP 5.6 End of Life (EOL) | Upgrade to Stable Version of PHP - PHP 7.3 PHP 5.6 End of Life (EOL) | Upgrade to Stable Version of PHP - PHP 7.3

Home  |  Resources  |  Threat & Vulnerability Management

PHP 5.6 End of Life (EOL): Upgrade to Stable Version of PHP

Written By: Zach Varnell

< Back to Blog Home

Vulnerabilities in PHP 5 Will Not Be Patched

Almost 14 years since its creation, PHP 5 has reached end-of-life as of January 2019.

The PHP team will no longer support the PHP 5.x branch via updates, bug fixes, or even security patches. This means any new or previously undiscovered vulnerabilities in PHP 5 will not be patched.

Upgrade to Stable Version of PHP

It is time to upgrade to the latest stable version of PHP, currently PHP 7.3.

Not only will this version receive updates and security fixes for several more years, but PHP 7.0 is also over two times faster than PHP 5, and PHP 7.3 is several percentage points faster than 7.0.

For web servers running modern off-the-shelf software, such as the latest versions of WordPress, upgrading may be as easy as updating configurations with your web host. The plugin PHP Compatibility Checker can be run for peace of mind.

PHP End of Life

For custom or in-house software, the code analyzers PHPCompatibility and Phan can be used to determine PHP 7 compatibility.

We are an international squad of professionals working as one.

logos